Dashboard issues
Incident Report for AirMap
Resolved
This incident has been resolved.
Posted Dec 11, 2019 - 06:39 UTC
Investigating
We are currently investigating this issue.
Posted Dec 11, 2019 - 00:23 UTC
This incident affected: Authority Services (Airspace Management).