Investigating a Degradation of Services
Incident Report for AirMap
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 17:58 UTC
Investigating
We're experiencing a degradation of services and are currently looking into the issue.
Posted Nov 19, 2019 - 17:46 UTC
This incident affected: Flight (Flight Plan, Briefing, Evaluation).