Investigating a Degradation of Services
Incident Report for AirMap
Resolved
This incident has been resolved.
Posted Oct 18, 2019 - 21:37 UTC
Investigating
We're experiencing a degradation of services and are currently looking into the issue.
Posted Oct 18, 2019 - 20:38 UTC
This incident affected: Flight (Flight, Flight Plan, Communication, Briefing, Evaluation) and Advisory (Airspace, Weather).