Experiencing delays in DNS
Incident Report for AirMap
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 21:47 UTC
Investigating
Currently experiencing extended delays in resolving dns. Investigating with service providers.
Posted Jul 17, 2020 - 21:20 UTC