Maintenance Window
Incident Report for AirMap
Resolved
This incident has been resolved.
Posted Oct 31, 2019 - 01:23 UTC
Identified
We're updating some services and there may be a brief interruption in responses
Posted Oct 30, 2019 - 23:23 UTC
This incident affected: Flight (Flight, Flight Plan, Briefing, Evaluation) and Advisory (Airspace, Weather).