Weather updates currently unavailable
Incident Report for AirMap
Resolved
Weather service has now been restored.
Posted Mar 02, 2021 - 01:07 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 01, 2021 - 18:15 UTC
This incident affected: Advisory (Weather).