Investigating a Degradation of Services
Incident Report for AirMap
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 15, 2019 - 06:36 UTC
Investigating
We're experiencing a degradation of services and are currently looking into the issue.
Posted 4 months ago. Mar 14, 2019 - 22:45 UTC
This incident affected: Telemetry (Traffic Alerts).